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Manipulacion de un robot omnidireccional con los gestos faciales

Manipulation of an omnidirectional robot with facial gestures
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Abstract:

This article describes the state of the art, showing the advances in research on different wireless electroencephalogram (EEG). It also
shows a prototype software that interprets the brain signals that come from the Emotiv Epoc headband, this process is called Brain
Computer Interface (BCI) that solves the problem of identifying EEG signals. The software, designed in Matlab, interprets brain
signals, which can be saved or manipulated in real time to move an omnidirectional robot with facial gestures. The software converts
brain signals to voltage to manipulate external manipulator devices. Currently this work is in the experimental testing phase in humans
and the non-invasive signal acquisition method is used; It is expected to extend this work to support people who have permanent or
temporary paralysis in the lower limbs, which also cause other types of psychological problems such as depression due to the use of
a wheelchair and the impact generated by not being able to move. autonomously from one place to another without the help of a third
person.
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Resumen:

Este articulo describe el estado del arte donde se muestra los avances de las investigaciones de los distintos dispositivos inalambricos
de emision de electroencefalograma (EEG). También muestra un software prototipo que interpreta las sefiales cerebrales que
provienen de la diadema Emotiv Epoc, este proceso es llamado Interface Cerebro Computadora (ICC) o BCI (por sus siglas en inglés
Brain Computer Interface) que resuelve el problema de identificacion de sefiales EEG. El software, disefiado en Matlab, interpreta las
sefiales cerebrales, las cuales se pueden guardar o manipular en tiempo real para mover un robot omnidireccional con los gestos
faciales. El software convierte las sefiales cerebrales a voltaje para manipular dispositivos manipuladores externos. Actualmente este
trabajo esta en la fase de pruebas experimentales en seres humanos y se emplea el método de adquisicion de la sefial no invasivo; se
espera extender este trabajo para apoyar a personas que tienen paralisis permanente o temporal en los miembros inferiores, que,
ademas, acarrean otro tipo de problemas psicologicos como la depresion por el uso de la silla de ruedas y el impacto que genera el no
poder movilizarse de manera autonoma de un lugar a otro sin ayuda de un tercero.
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Introduccion

Los campos mas estudiados por los investigadores
recientemente son el area de la robdtica y la medicina; y
los principales estudios estan enfocados al
comportamiento del cerebro humano. Las Interfaces
Cerebro-Computadora (ICC), también conocidas como
Brain-Computer Interfaces (BCI) en inglés, son sistemas
que permiten la comunicacioén y la interaccion directa entre
el cerebro humano y dispositivos externos. Las ICC
permiten que las sefales eléctricas generadas por el
cerebro sean traducidas en comandos que pueden
controlar dispositivos o aplicaciones, en este articulo se
emplea la diadema Emotiv Epoc+ como una ICC. En este
trabajo se presenta el desarrollo de un prototipo de una
interfaz  humano-computadora controlada a través de
gestos faciales utilizando la diadema Emotiv Epoc+.

En Chavez-Saenz, et. al. [1], se presentan un estudio de
las sefales electroencefalograficas (EEG) generadas
cuando una persona realiza una expresion facial como:
levantamiento de cejas, pestafieo, movimiento de los
labios cerrados hacia la derecha o hacia la izquierda. La
adquisicion de la sefial se realiza en tiempo real utilizando
el dispositivo Emotiv Epoc+ recolectando lecturas de una
muestra que considera hombres y mujeres de distintas
edades. Ademas, muestran los electroencefalogramas
obtenidos donde es posible observar el cambio de
caracteristicas de amplitud en las sefiales dependiendo de
la expresion facial realizada por el sujeto a prueba. Se
detalla la seleccion de la sefial con mayor actividad y el
resultado obtenido en términos de amplitud para
determinar diferencias cuantitativas entre la actividad de
las sefales para cada una de las expresiones. En la Figura
1 se muestran las sefiales de la diadema al gesto del
parpadeo.

Figura 1. Electrectroencefalograma con movimiento de
parpadeo[1].

En Hornero, et. al. muestran el disefio, implementacion y
evaluacion, tanto a nivel de hardware como a nivel de
software, de una interfaz gestual de bajo coste y consumo,
que puede ser utilizada desde diferentes partes del cuerpo
y que permite el acceso a cualquier plataforma digital, en
la Figura 2 muestra el software de control del robot Lego.
Las pruebas experimentales realizadas con el sistema,

tanto sobre software comercial, como con plataformas
educativas y de ocio, como un telescopio y un robot Lego
Mindstorm, han demostrado la posibilidad de obtener de
forma comoda hasta 6 elementos de control diferentes, y
la posibilidad de realizar un control cooperativo que
mejora el proceso de aprendizaje y la integracion social de
los usuarios [2].

Figura 2. Software para controlar el robot Lego [2].

En la Figura 3 muestra que las BCI son especialmente
relevantes para pacientes que sufren de trastornos de
movimiento: paralisis grave, esclerosis lateral amiotréfica,
o sindrome de locked-in, donde hay poca o ninguna
capacidad de control de movimiento residual. Sin
embargo, aun con esta tecnologia en desarrollo, en
México, muchos sitios de atencion médica para este tipo
de padecimientos no cuentan con un sistema BCI que, si
bien no es necesario en determinadas ocasiones, resulta
ser Util cuando el paciente tiene dificultades para
expresarse o realizar alguna accién consecuencia de su
padecimiento [3].

—3 | Brain-Computer
Interface

neuromuscular pathways

Figura 3. Una Interfaz Cerebro Computadora [3].

En Freire, et. al. realizan un proyecto en donde se
describe el disefio de un sistema para controlar una silla
de ruedas, mediante las sefales eléctricas cerebrales de
un paciente con paraplejia utilizando una interfaz cerebro-
computadora que interpretara las sefiales cerebrales al
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momento de realizar diferentes gestos faciales. Para la
deteccion de las sefales cerebrales relacionadas con la
atencién y el parpadeo ocular, utilizaron un casco
Neurosky que se conectaba mediante bluetooth a una
aplicacion en un dispositivo Android. Por otro lado, el
sistema de control se implementd utilizando un
microcontrolador Arduino, el cual se encargaba de
gestionar los movimientos de la silla [4]. En la Figura 4 se
muestra el programa empleado para la manipulacion de la
silla de ruedas.
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Figura 4. Software Labview para la manipulacion de la
silla [4].

En 2021 realizan un sistema de control y supervision para
el Robot  Scorbot a través de  sefales
electroencefalograficas (EEG). El sistema tiene la
capacidad de dirigir las articulaciones del Robot Scorbot
mediante sefales eléctricas generadas por la actividad
cerebral. Para lograr esto, se emplea los dispositivos
Neurosky y Emotiv Insight, que capturan los impulsos de
los electrodos y los transformaban en sefiales procesadas
a través del software matematico Matlab. En la fase de
control y supervision, se disefié una interfaz grafica que
permite al usuario entrenar y adaptar el sistema segun sus
limitaciones fisicas, cognitivas e intelectuales. De esta
manera, brinda la posibilidad de ajustar el funcionamiento
del sistema de acuerdo con las necesidades individuales
del usuario[5]. En la Figura 5 muestra la interfaz de
comunicacion usuario-maquina y la diadema.
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Figura 5. Interfaz BCI para la manipulacioén del robot [5].

En el 2022 [6] muestra el control de silla de ruedas BCI
utilizando un sistema experto que clasifica las sefiales de
EEG segun la estimacion del espectro de potencia y la
deteccion de tics nerviosos. Emplea un enfoque de disefio
de BCI (Interfaz Cerebro-Computadora) que incorporaba
inteligencia artificial para llevar a cabo un analisis
avanzado de sefales que contenian expresiones faciales,
utilizandolas como comandos de control. Estas sefales
presentaban diversos artefactos causados por tics
nerviosos simulados, como se muestra en la Figura 6. El
sistema experto propuesto consiste en dos redes
neuronales. La primera red permite el analisis de muestras
de un segundo de sefiales EEG provenientes de
electrodos especificos, basandose en estimaciones de
espectro de potencia de las formas de onda. Esto posibilita
la generacién de una sefial de control adecuada en
respuesta a los comandos de expresion facial
correspondientes. Por su parte, la segunda red neuronal
detectaba la aparicion y el tipo de tics nerviosos presentes

en la sefal.
<)
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L

Figura 6. Sistema completo con componentes [6].

De acuerdo con la Organizacion Mundial de la Salud entre
250 000 y 500 000 personas sufren cada afo en todo el
mundo lesiones medulares. Estas lesiones pueden obligar
a una persona a depender de sus cuidadores desde sus
actividades en la vida cotidiana hasta en sus necesidades
basicas. Sin embargo, con el uso de diversas tecnologias
asistenciales se puede lograr facilitar la movilidad, la
comunicacion, la auto asistencia o las actividades
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domeésticas. Es claro que la solucion definitiva a este
problema mundial es la introduccion masiva de robots
asistenciales que ayuden a personas de avanzada edad o
discapacitadas (entre ellas personas con paraplejia,
cuadriplejia u otras) que son dependientes en la
realizacion de sus tareas cotidianas como vestirse,
bafarse, realizar su aseo personal, comer, entre otras. En
[71 proponen un proyecto de investigacion para dar
solucién a la problematica de mejorar la calidad de vida e
independencia de las personas con paraplejia, ademas de
incluirlo socialmente. Este proyecto tiene como finalidad
ofrecer una solucion al problema de movilidad mediante el
disefio e implementacion de un robot omnidireccional
controlado por una persona con discapacidad, el disefio
es mostrado en la Figura 7.

Figura 7. Disefio de un sistema para controlar una silla
de ruedas [7].

Conceptualizacion

Homunculo de Penfield

Los homudnculos, término que proviene del
latin homunculus, significando «hombre pequefio», han
sido utilizados como medio de representacion de diversos
procesos biologicos en humanos desde hace tiempo.
Entre 1937 y 1954 el neurocirujano estadounidense Wilder
Penfield y sus colaboradores desarrollaron diversas
representaciones de un aspecto llamativo de la topografia
cerebral: la presencia de “mapas” de las vias nerviosas,
tanto las sensoriales como las motoras, en la corteza. Las
distintas funciones de nuestro organismo no se
encuentran representadas de forma proporcional en dicho
mapa, sino que su tamafno depende de la complejidad de
los nervios correspondientes. La representacion cortical
de los nervios motores y de los receptores cutaneos
correspondientes se situa en la corteza motora primaria,
en el surco central, una regién del I6bulo frontal que se
encuentra justo al lado de la corteza somestésica. La
corteza motora primaria es el area del cerebro mas
importante para el funcionamiento del sistema motor:
recibe aferencias del tdlamo y trabaja juntamente con el
resto de las regiones asociadas al movimiento, como la
corteza motora suplementaria, para elaborar y ejecutar
esquemas motores.

La Figura 8 muestra una representacion clasica del
Homdunculo de Penfield, presenta la mitad de cada region
del cortex, siendo la porcién izquierda la correspondiente
al area somatestésica también conocida como la corteza
somatosensorial, la cual es una region del cerebro que
juega un papel fundamental en la percepcidon de
sensaciones tactiles, de temperatura, de presion y de
posicion del cuerpo. En la Figura 9a, muestra el modelo
tradicional del Homunculo de Penfield que se ha venido
trabajando desde la década de los 50’s y la Figura 9b es
el mismo modelo actualizado incrustando las ultimas
investigaciones.
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Figura 8. Representacion del cerebro Homtnculo de
Penfield [8].

Electroencefalograma (EEG)

Un EEG es una herramienta médica que se utiliza para
registrar la actividad eléctrica del cerebro y es util en una
variedad de aplicaciones, como el diagndstico de
trastornos neuroldgicos y la monitorizacion durante
procedimientos médicos. Los EEG se pueden clasificar en
funcion de como se obtienen o adquieren los datos [9].

| b) Modelo Homiinculo de Penfield (2022)
a) Homiinculus de Penfield (1948) \

Figura 9. Homunculo de Penfield [9].

EEG Invasivo: Esta categoria se refiere a la adquisicion
de datos EEG mediante la insercion de electrodos dentro
del cerebro o en la superficie del cerebro. Esto suele
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requerir una cirugia minimamente invasiva para colocar
los electrodos directamente en el tejido cerebral. Este tipo
de EEG se utiliza en situaciones muy especificas, como la
evaluacion de la actividad cerebral en pacientes con
epilepsia grave o en cirugias cerebrales, ver Figura 10.

Figura 10. EEG Invasivo [10].

EEG Parcialmente Invasivo: Los electrodos se colocan en
la superficie del cuero cabelludo, pero pueden involucrar
algun grado de invasion o penetracion parcial en el tejido.
Por lo general, se utilizan electrodos subdurales o
epidurales, que se situan entre el craneo y la duramadre
(la membrana que recubre el cerebro). Esto se hace en
situaciones donde se necesita una mayor resolucion
espacial que la que ofrece un EEG no invasivo, pero no es
necesario un procedimiento completamente invasivo. En
la Figura 11, es un ejemplo de un implante minimamente
invasivo que integra electrodos, amplificacion,
procesamiento, potencia y telemetria para conectar y
controlar de forma inalambrica un sistema informatico
externo. En pacientes discapacitados, esto podria tener
multiples sistemas efectores de salida que van desde la
comunicacioén y el control ambiental hasta el control de
varias proétesis roboéticas[10].
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Figura 11. EEG Parcialmente Invasivo [10].

EEG No Invasivo: Esta es la forma mas comun de obtener
un EEG. En este caso, se colocan electrodos en la

superficie del cuero cabelludo sin ningun tipo de invasion,
como se observa en la Figura 12. Los electrodos estan
conectados a un dispositivo de registro que registra la
actividad eléctrica del cerebro. A pesar de su menor
resolucion espacial en comparacion con los métodos
invasivos o parcialmente invasivos, los EEG no invasivos
son seguros, comodos y ampliamente utilizados para una
variedad de propdsitos, como la investigacion clinica, el
diagnéstico de trastornos cerebrales y la monitorizacion
de pacientes en estado de coma o durante crisis
epilépticas [10].

.

Figura 12. EEG No Invasivo.

Interfaz Aumentada Cerebro Computadora

Dada la creciente investigacion y desarrollo de nuevas
técnicas para la implementacion de ICC, han surgido
nuevas aplicaciones que acoplan este tipo de interfaces
en la vida diaria mediante dispositivos de Interfaz
Aumentada Cerebro Computadora (ABCI por sus siglas
en inglés Augmented Brain Computer Interfaces).

Un ABCI es similar a una ICC, ya que se basan en bio-
sensores, los cuales graban sefales desde el cerebro en
entornos cotidianos y éstas se procesan en tiempo real
para monitorear el comportamiento del ser humano.

Para utilizar una ABCI como una técnica de imagen
cerebral mévil para todos los dias, en aplicaciones de la
vida real, los sensores y dispositivos correspondientes
deben ser de peso ligero y el tiempo de respuesta de los
equipos debe ser corto, en la Figura 13 se observan
diferentes dispositivos EEG mas comerciales [11],

[12],[13]1,[14]
P A
‘ & %

Emotiv NeuroSky Zeo Starlab
' » !
4
EmSense nia Game Controller Mindo 4 Mindo 16
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Figura 13. Dispositivos de EEG Moéviles mas usados.

Sistema Internacional 10-20

Una BCI analiza el comportamiento de patrones que se
originan en areas especificas del cerebro, y para obtener
registros consistentes de ciertas regiones especificas de
la cabeza, los cientificos se basan en un sistema estandar
para la colocacion exacta de electrodos llamado Sistema
Internacional 10-20. El sistema internacional 10-20 es
ampliamente utilizado en aplicaciones médicas y en la
investigacion  referente  a  Interfaces  Cerebro-
Computadora.

El nombre de 10-20 indica que los electrodos mas
frecuentemente utilizados estan colocados 10, 20, 20, 20,
20, y 10% del total de la distancia de Nasién-Inién como
se muestra Figura 14, los otros electrodos se colocan a
distancias similares fraccionadas[15].

Nasion

Nasion

P, -

Figure 14. Sistema Internacional 10-20.

Equipo experimental

En esta seccion se muestra el equipo experimental
empleado para realizar las pruebas experimentales del
robot omnidireccional y la diadema Emovit Epoc+.

Diadema Emotiv Epoc+

El EEG movil de 14 canales EMOTIV EPOC+ esta
disefado para la investigacion escalable y contextual del
cerebro humano y aplicaciones avanzadas de interfaz
cerebro-computadora y brinda acceso a datos cerebrales
de nivel profesional. Los 14 canales con los que cuenta
son: AF3, F7, F3, FC5, T7, P7, O1, 02, P8, T8, FC6, F4,
F8, AF4, como se muestra en la Figura 15, tiene 2
referencias: referencias CMS/DRL en P3/P4; alternativa
del proceso mastoideo izquierdo/derecho.

Figura 15. Canales y su distribucion [12].

Se conecta de manera inalambrica via bluetooth de bajo
consumo, el ancho de banda: 0,16 — 43 Hz, filtros notch
digitales a 50 Hz y 60 Hz, contiene un filtro Sinc digital
integrado de quinto orden. La duraciéon de la bateria:
hasta 12 horas con receptor USB, hasta 6 horas con
Bluetooth Low Energy. Las expresiones faciales capaces
de detectar son: parpadeo, guifio derecho e izquierdo,
sorpresa, cefio fruncido, sonrisa, apretar la mandibula,
risa. Tiene un peso de 170g y sus dimensiones son:
9x15x15cm. La diadema es mostrada en la Figura 16.

ML b

Figura 16. Diadema Emotiv EPOC+ [12].

Solucién cloruro de sodio Pisa 0.9%

La  solucion multipropdsito  contiene  agentes
antimicrobianos no alergénicos que ayudan a mantener
los sensores de la diadema frescos y evitan la
transferencia de microbios entre usuarios, ver Figura 17.
Cada 100 ml de solucion contienen:

e  Cloruro de sodio 0,9 g

e Composicién ionica: 16n sodio: 154 mmol/l (154
meq/l), ién cloruro: 154 mmol/l (154 meg/l)

e Osmolaridad tedrica: 308 mosm/I pH de 4,5-7,0.
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Figura 17. Solucién cloruro de sodio Pisa 0.9%.
Fuente propia.

Robot omnidireccional

Para realizar la prueba experimental se emplea un robot
movil omnidireccional como el que se muestra en la Figura
18, disefiado para moverse en cualquier direccion con la
finalidad de probar el seguimiento trayectoria de un
usuario, se emplea en un robot movil omnidireccional
educativo ya que son pruebas experimentales.

ESP32-can

e

Figura 18. Robot mévil omnidireccional.

EEG MATLAB

EEGLAB es una caja de herramientas Matlab interactiva
para procesar EEG, otros datos electrofisiolégicos
continuos y relacionados con eventos que incorporan
analisis de componentes independientes (ICA), analisis de

tiempo/frecuencia, rechazo de artefactos, estadisticas
relacionadas con eventos y varios modos Uutiles de
visualizacion del promedio, esta herramienta se utiliz6 al
momento de visualizar en Matlab la sefal con ayuda de
LSL (Lab Stream Layer) para ver y manipular las sefales
obtenidas con la diadema Emotiv en tiempo real[16].

EEGLAB proporciona una interfaz grafica de usuario (GUI)
interactiva que permite a los usuarios procesar de forma
flexible e interactiva su EEG de alta densidad y/o analisis
de tiempol/frecuencia (TFA), asi como promedios estandar
métodos, como se observa en la Figura 19. EEGLAB
también incorpora extensos tutoriales y ventanas de
ayuda, ademas de una funcion de historial de comandos
que facilita la transicion de los usuarios de la exploracion
de datos basada en GUI a la creacién y ejecucion de
scripts de analisis de datos personalizados o por lotes.

——No current dataset

- Create a new or load an existing dataset:
Use "File > Import data" (new)
Or "File > Load existing dataset" (old)

- If new,

"File > Import epoch info" (data epochs)
ﬂ:;‘ile > Import event info" (continuous data)

"Edit > Dataset info" (add/edit dataset
i“:ﬁle > Save dataset" (save dataset)

- Prune data: "Edit > Select data”

- Reject data: "Tools > Reject continuous

faE;;ch data: "Tools > Extract epochs"

- Remove baseline: "Tools > Remove baseline™

- Run ICA: "Tools > Run ICA"

Figura 19. GUI principal de EEGLAB [16].

Adquisicién de las sefiales

En esta seccion se muestra el procedimiento para la
adquisicion de las sefiales electroencefalograficas y
los gestos faciales, en la Figura 20 se describe en
orden cronoldgico los pasos para se deben seguir para
obtener una buena senal.

£ ™ '

R 4
\ \

el o X=

Figura 20. Algoritmo para la obtencién de la sefial
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Resultados

En la Figura 21 se muestra el algoritmo empleado para el
control del robot mévil omnidireccional a partir de las
sefales de los gestos faciales de las personas.

=
i y Comunicacién Comunicacién s\' 0
i inalambrica
| () {2

Adquisicién de Sefiales Procesamiento de

Experimento
EEG Sefiales y control

Figura 21. Algoritmo para la manipulacién del robot.

En la Figura 22 se observa el area de trabajo del robot, la
persona haciendo gestos, el programa para manipular el
robot omnidireccional y el mismo moévil, el experimento
consiste en mover el robot en su area de trabajo a través
de los gestos faciales de cualquier ser humano.

Figura 22. Manipulacion del robot por gestos faciales.

Conclusiones

La robotica movil y los gestos faciales desempenan un
papel cada vez mas importante en el campo médico, ya
que ofrece numerosas formas de apoyar: asistencia a
pacientes que no tienen movilidad.

La tetraplejia y la paraplejia son discapacidades que
resultan de las lesiones en la médula espinal y trastornos
neuromusculares tales como la paralisis cerebral. Los
pacientes que las padecen presentan diferentes niveles
de movimientos y actividad motora por lo que la
realizacion de tareas cotidianas, como puede ser el control
del entorno doméstico, es en muchas ocasiones todo un
reto. Por lo que, esta investigacion puede aportar para
superar este inconveniente a través de una diadema que
permita detectar los gestos faciales.

Los resultados obtenidos son muy buenos, se puede decir
que es viable llevar a cabo un proceso de entrenamiento
en el reconocimiento de expresiones faciales de cualquier
persona. Estas expresiones faciales son detectadas y
comprendidas por la aplicacion EEGLab, lo que a su vez
permite el control de la interfaz grafica encargada de
manipular los movimientos del robot. Es importante
destacar que, dado que cada persona es Unica y presenta
expresiones faciales distintas, se debe configurar para
cada usuario, debe completar este proceso de
entrenamiento antes de utilizar la interfaz del usuario. Este
entrenamiento personalizado garantiza una interaccion
efectiva entre el usuario y el robot.

Se propone como ftrabajo futuro la optimizacion del
algoritmo de deteccion de gestos faciales para lograr una
implementaciéon con mayor eficiencia, que requiera menor
poder computacional y obtenga resultados a mayor
velocidad para enviar al controlador y obtener mayor
exactitud en el movimiento del robot.
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